解决WordPress升级导致PHP版本兼容故障 附最新WP软件要求

解决WordPress升级导致PHP版本兼容故障 附最新WP软件要求

主机资讯有资源网2020-10-21 17:10:062A+A-

上午有同事告诉老左,在更新中的一个客户企业网站由于自己的误操作点击后台升级WordPress升级导致出现故障。于是老左让他将错误的提示问题发过来看看是什么。

Your server is running PHP version 5.4.45 but WordPress 5.4.2 requires at least 5.6.20.

可以看到提示的说明,因为当前的WordPress版本不兼容当前的低版本PHP。需要升级PHP才可以。这个问题老左以前也有遇到过,因为有些企业网站的客户仅仅是存放网站,确保可以打开即可,不需要运营推广的,所以不管他们。主要问题还是有些企业网站客户是自带过来的虚拟主机,本身PHP版本就比较老。

解决WordPress升级导致PHP版本兼容故障 附最新WP软件要求

我们可以看到当前[文]最新的PHP版本[章]是要求7.4,而[来]且MYSQL是5[自].6,如果我们是[有]PHP7.0还可[资]以将就使用,但是[源]也会提示要求升级[网]PHP。所以,如[文]果我们是虚拟 主机的话,你至少[章]需要升级到5.6[来]的PHP版本。如[自]果我们是低于这个[有]版本升级到WP最[资]新版本就直接出现[源]上面错误。

目前解决的办法是,我们去客户的企业网站所在的面板是否可以升级PHP,如果不可以升级只能将他搬迁到服务器中,因为我们大部分的服务器都是配置的PHP7.0+版本。看来以后的PHP需要7.4才可以,要不以后还是会麻烦。

声明: 本站仅为分享信息绝非推荐,网站不参与交易绝非中介,内容均仅代表个人观点绝非权威,读者请自行考虑后入手并自担风险!关于安全: 任何IDC都有倒闭和跑路的可能,出口线路更不可控,月付和备份是您的最佳选择,请保持良好的、有规则的备份习惯.

点击这里复制本文地址 以上内容由有资源网整理呈现,请务必在转载分享时注明本文地址!如对内容有疑问,请联系我们,谢谢!

支持Ctrl+Enter提交

有资源网 © All Rights Reserved.  Copyright uzyw. cn Rights Reserved.
Powered by Z-BlogPHP Themes by yiwuku.com
联系我们| 关于我们| 留言建议| 网站管理